You are here: Home » News Archive » 
EnglishDeutschFran├žaisNederlandsItaliano
Last update: 12/28/2011 21:51

Home

Search & Find


advanced search

Newsdetails

Test build wpa_supplicant v2.7

Wednesday March 14, 2018  By: Andi B.

I've made a test build of the newest wpa_supplicant code and uploaded it to https://bitbucket.org/Andi_B/os-2-wpa_supplicant/downloads/.

It can be used together with current xwlan builds. Simply replace the existing wpa_supplicant.exe and have fun.

From the readme.os2 -
###############################################################################
BetaTester installation intructions
- replace installed wpa_supplicant.exe with the included one
When using xwlan widget wpa_supplicant is usually found in
\util\xworkplace\plugins\xcenter\xwlan\.
When using the standalone wlanstat then in .\xwlan\.
- check if the new version is used by xwlan/wlanstat
right-click - properties - tab 'WPA supplicant' check version and path.
Something like v2.7-devel (OS/2-v2beta) should be shown.
- connect to wpa protected networks and post your findings at correspondending
thread at os2world.com
- you can also test wpa_supplicant with a .conf file. F.i. set up a profile
with no security, switch on wireless and start wpa_supplicant manually
(f.i. wpa_supplicant.exe -i lan1 -cwpa_supplicant.conf)
###############################################################################

If someone want to test feel free to post your findings here. If you're using the xcenter widget (in contrary to the standalone wlanstat.exe), be sure your ALT-F1 boot works or you've a working maintenance partition. I once saw a hang on my T60 at bootup of the xwlan widget with the new wpa_supplicant.

Category: Software, News, Press, and Net